Install problem

  1. 4 years ago


    Just trying to install. I run the composer command which works great...

    composer create-project wardrobe/wardrobe

    Then when I got to the url /install I get the Wardrobe install screen, my db config file is configured, I then hit "Install database &..." and I get

    copy(/home/****/Documents/www/wardrobe/public/packages/wardrobe/core/.gitkeep): failed to open stream: Permission denied
  2. rtablada

    Sep 14 Administrator

    Run `sudo chmod 777 app/config/packages/wardrobe/core/wardrobe.php` the installer is trying to change the config file and it needs file access to do this.

  3. ericbarnes

    Sep 14 Administrator

    Was you able to get this sorted out? It sounds like a permission issue so you could try to chmod the public dir and see if that makes a difference.

  4. I know this is an old thread but "chmod -R a+w app/public" worked for me

  5. To be honest guys, this composer create-project wardrobe/wardrobe always takes too long and its timed out all the time before completion. Is there another way to install wardrobe or is there a way to not have composer time out in 300s?

or Sign Up to reply!