Install problems

  1. 3 years ago

    I'm installing my first copy of wardrobe with composer create-project. Everything seems to be okay right up until the end and then I get:

    Script php artisan wardrobe:themes handling the post-create-project-cmd event returned with an error
    [RuntimeException]
    Error Output:
    [ErrorException]
    mkdir(): No such file or directory
    wardrobe:themes

    I'm guessing that means it's looking for the themes directory at the install root instead of public. I didn't think much of it, but wardrobe totally crashes after saving a new user during install.

    Class Wardrobe\Core\Models\User contains 3 abstract methods and must therefore be declared abstract or implement the remaining methods (Illuminate\Auth\UserInterface::getRememberToken, Illuminate\Auth\UserInterface::setRememberToken, Illuminate\Auth\UserInterface::getRememberTokenName)

    Are the two related?

  2. Apparently PHP 5.3 was the problem. I notice your requirements say >= 5.3.7, which is also what is on the Laravel docs. I don't think there is a 5.3.7. You can only get 5.3.28 from php.net. Maybe that's your way of saying at least 5.4, but >= 5.4 would be more clear.

    Once I worked with my host to use a different version of php, it worked just fine. I used 5.5 on the host and 5.4 on my laptop. Either one works.

  3. 2 years ago

    csanad

    May 27 Moderator Auckland, New Zealand

    There is a popular misunderstanding around php versions. 5.3.7 is lesser than 5.3.28 as 7 will be less than 28.

or Sign Up to reply!