(solved) Laravel newbie - Wardrobe/core problem

  1. 4 years ago
    Edited 4 years ago by ionutz2k

    Hi everybody!

    I'm starting a small app for myself using Laravel 4, of course =), and, like the laravel website says, I create my project using the composer command. So far so good!
    Afterwards I install Ryan's Laravel 4 Package Installer. Everything ok till' now.

    I run

    php artisan package:install wardrobe/core

    . It installs correctly.

    When i run

    php artisan wardrobe:config

    it gives:

    [InvalidArgumentException] Command "wardrobe:config" is not defined. Did you mean this? wardrobe:cofig

    So I run wardrobe:cofig and it works. (Saw that an issue is open on github but it's not fixed. I downloaded it 10 minutes ago).

    Afterwards, I run:

    php artisan config:publish wardrobe/core

    This one works!

    When I run this command:

    php artisan wardrobe:themes

    Gives this error:

    [InvalidArgumentException] The "C:\xampp\htdocs\site\public/packages/wardrobe/core/themes" directory does not exist. wardrobe:themes

    Finally, I migrate everything by running

    php artisan wardrobe:migrate

    Last part.
    I type localhost/site/public and it explodes! I don't touch anything

    InvalidArgumentException
    View [default.index] not found.
    throw new \InvalidArgumentException("View [$name] not found.");

    I think it's a routing problem.

    Am I doing something wrong?
    Please help me out.
    I'd like the blog to be up and runningbefore I start building the app.

    Best regards.

  2. Edited 4 years ago by ionutz2k

    Both of these routes can be configured using route group rules from the app/config/package/wardrobe/core/routes.php file.

    <?php
    
    return array(
    	'blog_group_rules' => array(
    		'prefix' => 'blog',              // I Just uncommented this and the site works.
    		// 'domain' => 'blog.site.com'
    	),
    
    	'admin_group_rules' => array(
    		'prefix' => 'wardrobe',
    		// 'domain' => 'blog.site.com'
    	),
    
    	'api_group_rules' => array(
    		'prefix' => 'api',
    		// 'domain' => 'blog.site.com'
    	),
    );

    But when I try and go to: http://localhost/site/public/blog it gives me the same error like before =(

  3. rtablada

    Sep 6 Administrator

    A few things to troubleshoot off of the bat. When you ran `artisan package:install` what version of wardrobe/core did you require.

    Then I need to add a command for publishing assets. (That is what is giving you the rest of your errors).

  4. Edited 4 years ago by ionutz2k

    I required 1.0.*

    Here's the output of the console:

    c:\xampp\htdocs\site>php artisan package:install wardrobe/core
    Please provide a version constraint for the wardrobe/core requirement: 1.0.*
    ./composer.json has been updated
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
      - Installing symfony/yaml (dev-master 6286e95)
        Loading from cache
    
      - Installing michelf/php-markdown (dev-lib 9dbd835)
        Loading from cache
    
      - Installing wardrobe/core (v1.0.0)
        Loading from cache
    
    Writing lock file
    Generating autoload files
    Generating optimized class loader
  5. rtablada

    Sep 6 Administrator

    1.0.0 didn't have the fix for the config bug. Try requiring dev-master.

    I just pushed an update to the theme:publisher to update the assets as well.

  6. I'm trying it right away! BRB

  7. It worked! Thanks a lot for the fast and awesome support.
    Everything's ok now.
    Cheers

  8. Sheldonsclark

    Sep 26 Rainbow Road Pasadena

    Also i want to do this app. how can i do it?

or Sign Up to reply!