ericbarnes

Administrator

Last active 2 years ago

  1. 2 years ago
    11 Jun 2014, 5:06pm GMT+0000
    ericbarnes posted in Trouble with <!-- more --> button.

    That isn't included so you have full flexibility to do it however you want. :)

    One way would be to just that

    {{ $post->parsed_intro }}

    Then under it add the link manually. So your end result would be something like:

    {{ $post->parsed_intro }}
    <a href="{{ wardrobe_url('/post/'.$post->slug) }}">Read More</a>
  2. 3 Jun 2014, 5:04pm GMT+0000
    ericbarnes posted in Trouble with <!-- more --> button.

    Sorry for the delay. When you are looping your posts you need to use:

    {{ $post->parsed_intro }}

    Instead of:

    {{ $post->parsedContent }}
  3. 3 years ago
    20 Nov 2013, 4:39pm GMT+0000
    ericbarnes posted in How do these routes work?.

    What it does is inject it's own routes via the service provider of the package. Here is the place:
    https://github.com/wardrobecms/core/blob/master/src/Wardrobe/Core/WardrobeServiceProvider.php#L28

  4. 20 Nov 2013, 4:37pm GMT+0000

    Yes right now you can select any user since we don't have any groups to limit it. I guess you could in theory you could add a display:none on that field so it wouldn't show but until user groups are added I think it's going to remain.

  5. 7 Oct 2013, 11:30am GMT+0000

    Currently there is no distinction. If they are a registered user they can write posts. In the future we might could add a few simple user level but this was never planned when I built Wardrobe.

  6. 7 Oct 2013, 12:00am GMT+0000

    This one is probably kind of tricky. My only two thoughts are

    1. having a separate install and setting up the users you choose.
    2. Modifying the users table with some type of flag saying if they can post. Then modifying the DbUserRepository.php and checking against this flag.

    I like the sound of option 2 better but I would probably try and figure out a clean way and sending a pull request that way it will be in the core for future releases.

    On the forum I have never used Vanilla so I can't share anything about that.

  7. 3 Oct 2013, 11:50am GMT+0000

    Yes this was a new change introduced in Laravel. Here is the commit with the fix if you want to patch it manually:
    https://github.com/wardrobecms/core/issues/56

    Or set your composer.json to `"wardrobe/core": "dev-master"` and run `composer update`

  8. 19 Sep 2013, 5:07pm GMT+0000
    ericbarnes posted in Wardrobe on fortrabbit.com.

    I've never used Fortrabbit but someone on twitter says:

    You can ssh in, cd to htdocs and run artisan as usual. Works like a charm!

    https://twitter.com/mgustafsson/status/380733308042510336

  9. 16 Sep 2013, 8:03pm GMT+0000

    I remember some of these as being bugs that have been fixed. Sounds like our versions might be messed up in composer. Can you try changing your composer.json to require a specific version and then run the steps again?

    "wardrobe/core": "1.0.1"

    or edge version:

    "wardrobe/core": "dev-master"
  10. 16 Sep 2013, 7:02pm GMT+0000

    Yeah Matalina I believe you are correct. I am pretty sure on a mac (which I am) some version of php comes installed by default. But it's always the first thing I do so I'm not positive.

View more