ionutz2k

Member

Last active 4 years ago

  1. 4 years ago
    19 Sep 2013, 5:08pm GMT+0000
    ionutz2k posted in Wardrobe on fortrabbit.com.

    Thank you, Eric. I'll try it.

    Update:
    As the tweet says:

    Works like a charm!

    Thanks again!

  2. 19 Sep 2013, 12:26pm GMT+0000
    ionutz2k started the conversation Wardrobe on fortrabbit.com.

    Hi!
    I managed to push wardrobe to fortrabbit following Fortrabbit Docs - Laravel 4 Cookbook

    Using git commit -am 'Laravel 4 install [trigger:composer]' it triggers the composer. And this worked.

    But now I can't find a way to migrate wardrobe to the database.

    How do I use artisan on fortrabbit?

  3. 13 Sep 2013, 12:21pm GMT+0000

    What a noob!
    Thank you!

  4. 13 Sep 2013, 1:00am GMT+0000

    I'm trying to make Wardrobe to use another database.
    When I run php artisan wardrobe:migrate it says:
    [InvalidArgumentException] Database [wardrobe] not configured. wardrobe:migrate
    These are the changes that I made:

    app/config/packageswardrobe/core/database.php
    
    <?php
    
    return array(
    	'default' => 'connections',
    
    	'connections' => array(
    
    		'sqlite' => array(
    			'driver'   => 'sqlite',
    			'database' => app_path().'/database/wardrobe.sqlite',
    			'prefix'   => '',
    		),
    
    		'mysql' => array(
    			'driver'    => 'mysql',
    			'host'      => 'localhost',
    			'database'  => 'site_wardrobe',
    			'username'  => 'root',
    			'password'  => '',
    			'charset'   => 'utf8',
    			'collation' => 'utf8_unicode_ci',
    			'prefix'    => '',
    		),
    
    		'pgsql' => array(
    			'driver'   => 'pgsql',
    			'host'     => 'localhost',
    			'database' => 'database',
    			'username' => 'root',
    			'password' => '',
    			'charset'  => 'utf8',
    			'prefix'   => '',
    			'schema'   => 'public',
    		),
    
    		'sqlsrv' => array(
    			'driver'   => 'sqlsrv',
    			'host'     => 'localhost',
    			'database' => 'database',
    			'username' => 'root',
    			'password' => '',
    			'prefix'   => '',
    		),
    
    	),
    );

    Even if I change the file the error persists. If I set it to default it creates the tables on the other database, that I use for the website.
    Github Readme file says :

    If the default configuration is set to default it will use the host application connection. Otherwise, it will use the connection details listed in this connection array.

    Am I doing something wrong?

  5. 6 Sep 2013, 11:16pm GMT+0000

    It worked! Thanks a lot for the fast and awesome support.
    Everything's ok now.
    Cheers

  6. 6 Sep 2013, 11:08pm GMT+0000

    I'm trying it right away! BRB

  7. 6 Sep 2013, 10:53pm GMT+0000

    I required 1.0.*

    Here's the output of the console:

    c:\xampp\htdocs\site>php artisan package:install wardrobe/core
    Please provide a version constraint for the wardrobe/core requirement: 1.0.*
    ./composer.json has been updated
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
      - Installing symfony/yaml (dev-master 6286e95)
        Loading from cache
    
      - Installing michelf/php-markdown (dev-lib 9dbd835)
        Loading from cache
    
      - Installing wardrobe/core (v1.0.0)
        Loading from cache
    
    Writing lock file
    Generating autoload files
    Generating optimized class loader
  8. 6 Sep 2013, 10:36pm GMT+0000

    Both of these routes can be configured using route group rules from the app/config/package/wardrobe/core/routes.php file.

    <?php
    
    return array(
    	'blog_group_rules' => array(
    		'prefix' => 'blog',              // I Just uncommented this and the site works.
    		// 'domain' => 'blog.site.com'
    	),
    
    	'admin_group_rules' => array(
    		'prefix' => 'wardrobe',
    		// 'domain' => 'blog.site.com'
    	),
    
    	'api_group_rules' => array(
    		'prefix' => 'api',
    		// 'domain' => 'blog.site.com'
    	),
    );

    But when I try and go to: http://localhost/site/public/blog it gives me the same error like before =(

  9. 6 Sep 2013, 10:31pm GMT+0000
    ionutz2k started the conversation (solved) Laravel newbie - Wardrobe/core problem.

    Hi everybody!

    I'm starting a small app for myself using Laravel 4, of course =), and, like the laravel website says, I create my project using the composer command. So far so good!
    Afterwards I install Ryan's Laravel 4 Package Installer. Everything ok till' now.

    I run

    php artisan package:install wardrobe/core

    . It installs correctly.

    When i run

    php artisan wardrobe:config

    it gives:

    [InvalidArgumentException] Command "wardrobe:config" is not defined. Did you mean this? wardrobe:cofig

    So I run wardrobe:cofig and it works. (Saw that an issue is open on github but it's not fixed. I downloaded it 10 minutes ago).

    Afterwards, I run:

    php artisan config:publish wardrobe/core

    This one works!

    When I run this command:

    php artisan wardrobe:themes

    Gives this error:

    [InvalidArgumentException] The "C:\xampp\htdocs\site\public/packages/wardrobe/core/themes" directory does not exist. wardrobe:themes

    Finally, I migrate everything by running

    php artisan wardrobe:migrate

    Last part.
    I type localhost/site/public and it explodes! I don't touch anything

    InvalidArgumentException
    View [default.index] not found.
    throw new \InvalidArgumentException("View [$name] not found.");

    I think it's a routing problem.

    Am I doing something wrong?
    Please help me out.
    I'd like the blog to be up and runningbefore I start building the app.

    Best regards.

  10. 6 Sep 2013, 1:46pm GMT+0000

    nice job!
    will you post the source code of the website?

View more